const regex = /(^|\s)[а-я]{1,2}(\s|$)([а-я]{1,2}(\s|$)){0,4}/gui;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\s)[а-я]{1,2}(\\s|$)([а-я]{1,2}(\\s|$)){0,4}', 'gui')
const str = `и слова на ветер и не более да`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}