// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ui)(^|\s)[а-я]{1,2}(\s|$)([а-я]{1,2}(\s|$)){0,4}").unwrap();
let string = "и слова на ветер и не более да";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}