package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(^|\s)[а-я]{1,2}(\s|$)([а-я]{1,2}(\s|$)){0,4}`)
var str = `и слова на ветер и не более да`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}