re = /(^|\s)[а-я]{1,2}(\s|$)([а-я]{1,2}(\s|$)){0,4}/i
str = 'и слова на ветер и не более да'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end