$re = '/(^|\s)[а-я]{1,2}(\s|$)([а-я]{1,2}(\s|$)){0,4}/ui';
$str = 'и слова на ветер и не более да';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);