# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!insertedAT\": )\{ \"\$date\": (\"[^\"]*\") \},/\1/i;t' <<< "\"insertedAt\": { \"$date\": \"2018-01-31T11:05:39.447Z\" },"