import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!insertedAT\\\": )\\{ \\\"\\$date\\\": (\\\"[^\\\"]*\\\") \\},";
final String string = "\"insertedAt\": { \"$date\": \"2018-01-31T11:05:39.447Z\" },";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}