use strict;
my $str = '"insertedAt": { "$date": "2018-01-31T11:05:39.447Z" },';
my $regex = qr/(?!insertedAT\": )\{ \"\$date\": (\"[^\"]*\") \},/ip;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";