$re = '/(?!insertedAT\": )\{ \"\$date\": (\"[^\"]*\") \},/i';
$str = '"insertedAt": { "$date": "2018-01-31T11:05:39.447Z" },';
$subst = "\1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;