using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!insertedAT\"": )\{ \""\$date\"": (\""[^\""]*\"") \},";
string substitution = @"\1";
string input = @"""insertedAt"": { ""$date"": ""2018-01-31T11:05:39.447Z"" },";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}