re = /(?!insertedAT\": )\{ \"\$date\": (\"[^\"]*\") \},/i
str = '"insertedAt": { "$date": "2018-01-31T11:05:39.447Z" },'
subst = '\\1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result