using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"token=([^;]+)";
string input = @"Fri, 22 Feb 2019 22:39:19 GMT',
'application/json',
'76',
'close',
[ 'token=fCMNSX6y85W.7jOzwvpp8GQ; Secure; HttpOnly; expires=Wed, 21 Oct 2099 04:24:00 GMT' ],
'content-type,cache-control,pragma,x-request-id',
'true' ] '";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}