package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)token=([^;]+)`)
var str = `Fri, 22 Feb 2019 22:39:19 GMT',
'application/json',
'76',
'close',
[ 'token=fCMNSX6y85W.7jOzwvpp8GQ; Secure; HttpOnly; expires=Wed, 21 Oct 2099 04:24:00 GMT' ],
'content-type,cache-control,pragma,x-request-id',
'true' ] '`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}