import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "token=([^;]+)";
final String string = "Fri, 22 Feb 2019 22:39:19 GMT',\n"
+ " 'application/json',\n"
+ " '76',\n"
+ " 'close',\n"
+ " [ 'token=fCMNSX6y85W.7jOzwvpp8GQ; Secure; HttpOnly; expires=Wed, 21 Oct 2099 04:24:00 GMT' ],\n"
+ " 'content-type,cache-control,pragma,x-request-id',\n"
+ " 'true' ] '";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}