// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)token=([^;]+)").unwrap();
let string = "Fri, 22 Feb 2019 22:39:19 GMT',
'application/json',
'76',
'close',
[ 'token=fCMNSX6y85W.7jOzwvpp8GQ; Secure; HttpOnly; expires=Wed, 21 Oct 2099 04:24:00 GMT' ],
'content-type,cache-control,pragma,x-request-id',
'true' ] '";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}