use strict;
my $str = 'Fri, 22 Feb 2019 22:39:19 GMT\',
\'application/json\',
\'76\',
\'close\',
[ \'token=fCMNSX6y85W.7jOzwvpp8GQ; Secure; HttpOnly; expires=Wed, 21 Oct 2099 04:24:00 GMT\' ],
\'content-type,cache-control,pragma,x-request-id\',
\'true\' ] \'';
my $regex = qr/token=([^;]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}