#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=(?:\D*\d\D*){8,14}$)[- \d()+]*"
Local $sString = "01 02 03 04 05" & @CRLF & _
"0102030405" & @CRLF & _
"+33102030405" & @CRLF & _
"01-02-03-04-05" & @CRLF & _
"01.02.03.04.05" & @CRLF & _
"+33 1 02 03 04 053" & @CRLF & _
"(+33)102030405"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")