use strict;
my $str = '01 02 03 04 05
0102030405
+33102030405
01-02-03-04-05
01.02.03.04.05
+33 1 02 03 04 053
(+33)102030405';
my $regex = qr/(?=(?:\D*\d\D*){8,14}$)[- \d()+]*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}