using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(?:\D*\d\D*){8,14}$)[- \d()+]*";
string input = @"01 02 03 04 05
0102030405
+33102030405
01-02-03-04-05
01.02.03.04.05
+33 1 02 03 04 053
(+33)102030405";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}