import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(?:\\D*\\d\\D*){8,14}$)[- \\d()+]*";
final String string = "01 02 03 04 05\n"
+ "0102030405\n"
+ "+33102030405\n"
+ "01-02-03-04-05\n"
+ "01.02.03.04.05\n"
+ "+33 1 02 03 04 053\n"
+ "(+33)102030405";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}