import re
regex = re.compile(r"(?=(?:\D*\d\D*){8,14}$)[- \d()+]*", flags=re.MULTILINE)
test_str = ("01 02 03 04 05\n"
"0102030405\n"
"+33102030405\n"
"01-02-03-04-05\n"
"01.02.03.04.05\n"
"+33 1 02 03 04 053\n"
"(+33)102030405")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")