const regex = /\\u([a-z0-9]+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\u([a-z0-9]+)', 'gi')
const str = `\\u302D`;
const subst = `\\x{$1}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);