$re = '/\\\\u([a-z0-9]+)/i';
$str = '\\u302D';
$subst = "\\x{$1}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;