import Foundation
let pattern = #"\\u([a-z0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"\u302D"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\x{$1}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)