using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\([0-9]\)\s+([^.!?]+[.!?])|([A-Z].*?\.)(?: |$))";
string input = @"(1) A first sentence, that always follows a number in parantheses. This is my second sentence. This is my third sentence, (...) .";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}