import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\([0-9]\\)\\s+([^.!?]+[.!?])|([A-Z].*?\\.)(?: |$))";
final String string = "(1) A first sentence, that always follows a number in parantheses. This is my second sentence. This is my third sentence, (...) .";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}