re = /(?:\([0-9]\)\s+([^.!?]+[.!?])|([A-Z].*?\.)(?: |$))/m
str = '(1) A first sentence, that always follows a number in parantheses. This is my second sentence. This is my third sentence, (...) .'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end