package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\([0-9]\)\s+([^.!?]+[.!?])|([A-Z].*?\.)(?: |$))`)
var str = `(1) A first sentence, that always follows a number in parantheses. This is my second sentence. This is my third sentence, (...) .`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}