const regex = new RegExp('(?:\\([0-9]\\)\\s+([^.!?]+[.!?])|([A-Z].*?\\.)(?: |$))', 'gm')
const str = `(1) A first sentence, that always follows a number in parantheses. This is my second sentence. This is my third sentence, (...) .`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}