$re = '/(?:\([0-9]\)\s+([^.!?]+[.!?])|([A-Z].*?\.)(?: |$))/m';
$str = '(1) A first sentence, that always follows a number in parantheses. This is my second sentence. This is my third sentence, (...) .';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);