using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{1,3}°\d{1,3}'\d{1,3}\.\d\""[N|S]\s\d{1,3}°\d{1,3}'\d{1,3}\.\d\""[E|W]";
string input = @"73°10'50.3""N 98°06'02.9""W
36°10'13.6""N 115°08'23.6""W
115°10'13.6""N 115°08'23.6""W
36°101'13.6""N 115°08'23.6""W
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}