import re
regex = re.compile(r"\d{1,3}°\d{1,3}'\d{1,3}\.\d\"[N|S]\s\d{1,3}°\d{1,3}'\d{1,3}\.\d\"[E|W]", flags=re.MULTILINE)
test_str = ("73°10'50.3\"N 98°06'02.9\"W\n"
"36°10'13.6\"N 115°08'23.6\"W\n"
"115°10'13.6\"N 115°08'23.6\"W\n"
"36°101'13.6\"N 115°08'23.6\"W\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")