const regex = new RegExp('\\d{1,3}°\\d{1,3}\\'\\d{1,3}\\.\\d\\"[N|S]\\s\\d{1,3}°\\d{1,3}\\'\\d{1,3}\\.\\d\\"[E|W]', 'gm')
const str = `73°10'50.3"N 98°06'02.9"W
36°10'13.6"N 115°08'23.6"W
115°10'13.6"N 115°08'23.6"W
36°101'13.6"N 115°08'23.6"W
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}