// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\d{1,3}°\d{1,3}'\d{1,3}\.\d\"[N|S]\s\d{1,3}°\d{1,3}'\d{1,3}\.\d\"[E|W]"#).unwrap();
let string = "73°10'50.3\"N 98°06'02.9\"W
36°10'13.6\"N 115°08'23.6\"W
115°10'13.6\"N 115°08'23.6\"W
36°101'13.6\"N 115°08'23.6\"W
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}