package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{1,3}°\d{1,3}'\d{1,3}\.\d\"[N|S]\s\d{1,3}°\d{1,3}'\d{1,3}\.\d\"[E|W]`)
var str = `73°10'50.3"N 98°06'02.9"W
36°10'13.6"N 115°08'23.6"W
115°10'13.6"N 115°08'23.6"W
36°101'13.6"N 115°08'23.6"W
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}