using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(?!\d)";
string substitution = @"";
string input = @"a,b,a.b,a.,1,2,1.2,1.,.,11,222,11.222,11.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}