$re = '/\.(?!\d)/';
$str = 'a,b,a.b,a.,1,2,1.2,1.,.,11,222,11.222,11.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;