re = /\.(?!\d)/
str = 'a,b,a.b,a.,1,2,1.2,1.,.,11,222,11.222,11.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result