using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?x:#sds
)
(?#sdsa)
#sda
(?x) # extended mode)
(?<!\\) # no escape in before paren)
(?: # begine or end alternation noncap group)
(?<begin>\( # begining pattern paren)
(?: # name/index/noncap alternation noncap group)
(?<named>\?\< # named ?<name>)
(?<name>[\w][\w\d_]+) # capture name)
>)| # end of name >)
(?<indexed>(?!\?))| # indexed capture group no following ? after paren)
(?<nonecap>\?[^<]) # other groups that dont capture no following < after paren)
) # name/index/noncap alternation noncap group)
)| # begining pattern end)
(?<end>\)) # ending paren ends group scope)
)";
string input = @"(?x) # extended mode
(?<!\\) # no escape in before paren
(?: # begine or end alternation noncap group
(?<begin>\( # begining pattern paren
(?: # name/index/noncap alternation noncap group
(?<named>\?\< # named ?<name>
(?<name>[\w][\w\d_]+) # capture name
>)| # end of name >
(?<indexed>(?!\?))| # indexed capture group no following ? after paren
(?<nonecap>\?[^<]) # other groups that dont capture no following < after paren
) # name/index/noncap alternation noncap group
)| # begining pattern end
(?<end>\)) # ending paren ends group scope
)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}