$re = '/(?x:#sds
)
(?#sdsa)
#sda
(?x) # extended mode)
(?<!\\\\) # no escape in before paren)
(?: # begine or end alternation noncap group)
(?<begin>\( # begining pattern paren)
(?: # name/index/noncap alternation noncap group)
(?<named>\?\< # named ?<name>)
(?<name>[\w][\w\d_]+) # capture name)
>)| # end of name >)
(?<indexed>(?!\?))| # indexed capture group no following ? after paren)
(?<nonecap>\?[^<]) # other groups that dont capture no following < after paren)
) # name/index/noncap alternation noncap group)
)| # begining pattern end)
(?<end>\)) # ending paren ends group scope)
)/m';
$str = '(?x) # extended mode
(?<!\\\\) # no escape in before paren
(?: # begine or end alternation noncap group
(?<begin>\\( # begining pattern paren
(?: # name/index/noncap alternation noncap group
(?<named>\\?\\< # named ?<name>
(?<name>[\\w][\\w\\d_]+) # capture name
>)| # end of name >
(?<indexed>(?!\\?))| # indexed capture group no following ? after paren
(?<nonecap>\\?[^<]) # other groups that dont capture no following < after paren
) # name/index/noncap alternation noncap group
)| # begining pattern end
(?<end>\\)) # ending paren ends group scope
)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);