// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?x:#sds
)
(?#sdsa)
#sda
(?x) # extended mode)
(?<!\\) # no escape in before paren)
(?: # begine or end alternation noncap group)
(?<begin>\( # begining pattern paren)
(?: # name/index/noncap alternation noncap group)
(?<named>\?\< # named ?<name>)
(?<name>[\w][\w\d_]+) # capture name)
>)| # end of name >)
(?<indexed>(?!\?))| # indexed capture group no following ? after paren)
(?<nonecap>\?[^<]) # other groups that dont capture no following < after paren)
) # name/index/noncap alternation noncap group)
)| # begining pattern end)
(?<end>\)) # ending paren ends group scope)
)").unwrap();
let string = "(?x) # extended mode
(?<!\\\\) # no escape in before paren
(?: # begine or end alternation noncap group
(?<begin>\\( # begining pattern paren
(?: # name/index/noncap alternation noncap group
(?<named>\\?\\< # named ?<name>
(?<name>[\\w][\\w\\d_]+) # capture name
>)| # end of name >
(?<indexed>(?!\\?))| # indexed capture group no following ? after paren
(?<nonecap>\\?[^<]) # other groups that dont capture no following < after paren
) # name/index/noncap alternation noncap group
)| # begining pattern end
(?<end>\\)) # ending paren ends group scope
)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}