import re
regex = re.compile((r"(?x:#sds\n"
r")\n"
r"(?#sdsa)\n"
r"#sda\n"
r"(?x) # extended mode)\n"
r"(?<!\\) # no escape in before paren)\n"
r"(?: # begine or end alternation noncap group)\n"
r" (?<begin>\( # begining pattern paren)\n"
r" (?: # name/index/noncap alternation noncap group)\n"
r" (?<named>\?\< # named ?<name>)\n"
r" (?<name>[\w][\w\d_]+) # capture name)\n"
r" >)| # end of name >)\n"
r" (?<indexed>(?!\?))| # indexed capture group no following ? after paren)\n"
r" (?<nonecap>\?[^<]) # other groups that dont capture no following < after paren)\n"
r" ) # name/index/noncap alternation noncap group)\n"
r" )| # begining pattern end)\n"
r" (?<end>\)) # ending paren ends group scope)\n"
r")"), flags=re.MULTILINE)
test_str = ("(?x) # extended mode\n"
"(?<!\\\\) # no escape in before paren\n"
"(?: # begine or end alternation noncap group\n"
" (?<begin>\\( # begining pattern paren\n"
" (?: # name/index/noncap alternation noncap group\n"
" (?<named>\\?\\< # named ?<name>\n"
" (?<name>[\\w][\\w\\d_]+) # capture name\n"
" >)| # end of name >\n"
" (?<indexed>(?!\\?))| # indexed capture group no following ? after paren\n"
" (?<nonecap>\\?[^<]) # other groups that dont capture no following < after paren\n"
" ) # name/index/noncap alternation noncap group\n"
" )| # begining pattern end\n"
" (?<end>\\)) # ending paren ends group scope\n"
")")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")