#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\S)(?:(?:https?|www)\S+|/+(?!\S))(*SKIP)(*F)|/"
Local $sString = "Color/Colour" & @CRLF & _
"American English/British English" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://usa.gov/about" & @CRLF & _
"www.gov.uk/about" & @CRLF & _
"/" & @CRLF & _
" / / / /" & @CRLF & _
"////"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")