const regex = new RegExp('(?<!\\S)(?:(?:https?|www)\\S+|/+(?!\\S))(*SKIP)(*F)|/', 'gm')
const str = `Color/Colour
American English/British English
https://usa.gov/about
www.gov.uk/about
/
/ / / /
////`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}