import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)(?:(?:https?|www)\\S+|/+(?!\\S))(*SKIP)(*F)|/";
final String string = "Color/Colour\n"
+ "American English/British English\n\n\n"
+ "https://usa.gov/about\n"
+ "www.gov.uk/about\n"
+ "/\n"
+ " / / / /\n"
+ "////";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}