$re = '~(?<!\S)(?:(?:https?|www)\S+|/+(?!\S))(*SKIP)(*F)|/~m';
$str = 'Color/Colour
American English/British English
https://usa.gov/about
www.gov.uk/about
/
/ / / /
////';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);