using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\s*)case\s+([^:]*?)\s*:(.*?)\s*break;?";
string substitution = @"$1$2 -> {$3\n$1}";
string input = @"switch (new Date().getDay()) {
case 0:
day = ""Sunday"";
break;
case 1:
day = ""Monday"";
break;
case 2:
day = ""Tuesday"";
break;
case 3:
day = ""Wednesday"";
break;
case 4:
day = ""Thursday"";
break;
case 5:
day = ""Friday"";
break;
case 6:
day = ""Saturday"";
break;
}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}