import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\s*)case\\s+([^:]*?)\\s*:(.*?)\\s*break;?";
final String string = "switch (new Date().getDay()) {\n"
+ " case 0:\n"
+ " day = \"Sunday\";\n"
+ " break;\n"
+ " case 1:\n"
+ " day = \"Monday\";\n"
+ " break;\n"
+ " case 2:\n"
+ " day = \"Tuesday\";\n"
+ " break;\n"
+ " case 3:\n"
+ " day = \"Wednesday\";\n"
+ " break;\n"
+ " case 4:\n"
+ " day = \"Thursday\";\n"
+ " break;\n"
+ " case 5:\n"
+ " day = \"Friday\";\n"
+ " break;\n"
+ " case 6:\n"
+ " day = \"Saturday\";\n"
+ " break;\n"
+ "}";
final String subst = "$1$2 -> {$3\\n$1}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}