# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\s*)case\s+([^:]*?)\s*:(.*?)\s*break;?"
test_str = ("switch (new Date().getDay()) {\n"
" case 0:\n"
" day = \"Sunday\";\n"
" break;\n"
" case 1:\n"
" day = \"Monday\";\n"
" break;\n"
" case 2:\n"
" day = \"Tuesday\";\n"
" break;\n"
" case 3:\n"
" day = \"Wednesday\";\n"
" break;\n"
" case 4:\n"
" day = \"Thursday\";\n"
" break;\n"
" case 5:\n"
" day = \"Friday\";\n"
" break;\n"
" case 6:\n"
" day = \"Saturday\";\n"
" break;\n"
"}")
subst = "$1$2 -> {$3\\n$1}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.