// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)^(\s*)case\s+([^:]*?)\s*:(.*?)\s*break;?").unwrap();
let string = "switch (new Date().getDay()) {
case 0:
day = \"Sunday\";
break;
case 1:
day = \"Monday\";
break;
case 2:
day = \"Tuesday\";
break;
case 3:
day = \"Wednesday\";
break;
case 4:
day = \"Thursday\";
break;
case 5:
day = \"Friday\";
break;
case 6:
day = \"Saturday\";
break;
}";
let substitution = "$1$2 -> {$3\\n$1}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}